设为首页收藏本站language 语言切换
查看: 1725|回复: 7
收起左侧

[求助] EIGRP 和OSPF双点双向重分发解决次优路径问题

[复制链接]
发表于 2017-3-16 12:19:38 | 显示全部楼层 |阅读模式
100鸿鹄币
QQ截图20170316112800.jpg
求助: 到R4到 1.1.1.1 实现R2R3 负载
            到R1 到4.4.4.4 实现R2R3负载
             到各个网段实现最优路径
配置
      R1     
           interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 123.1.1.1 255.255.255.0
!
interface Ethernet0/1
ip address 13.13.13.1 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
!
router eigrp 100
network 1.1.1.1 0.0.0.0
network 13.13.13.0 0.0.0.255
network 123.1.1.0 0.0.0.255

1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      2.0.0.0/32 is subnetted, 1 subnets
D EX     2.2.2.2 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      3.0.0.0/32 is subnetted, 1 subnets
D EX     3.3.3.3 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      4.0.0.0/32 is subnetted, 1 subnets
D EX     4.4.4.4 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        13.13.13.0/24 is directly connected, Ethernet0/1
L        13.13.13.1/32 is directly connected, Ethernet0/1
      24.0.0.0/24 is subnetted, 1 subnets
D EX     24.1.1.0 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      34.0.0.0/24 is subnetted, 1 subnets
D EX     34.1.1.0 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      123.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        123.1.1.0/24 is directly connected, Ethernet0/0
L        123.1.1.1/32 is directly connected, Ethernet0/0




R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
ip address 123.1.1.2 255.255.255.0
!
interface Ethernet0/2
ip address 24.1.1.2 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
!
router eigrp 100
network 123.1.1.0 0.0.0.255
redistribute ospf 100 metric 1000 100 255 1 150
!
router ospf 100
redistribute eigrp 100 metric-type 1 subnets
network 2.2.2.2 0.0.0.0 area 0
network 24.1.1.0 0.0.0.255 area 0
distance 180 3.3.3.3 0.0.0.0


R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
ip address 13.13.13.2 255.255.255.0
!
interface Ethernet0/2
ip address 123.1.1.3 255.255.255.0
!
interface Ethernet0/3
ip address 34.1.1.3 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
!
router eigrp 100
network 13.13.13.0 0.0.0.255
network 123.1.1.0 0.0.0.255
redistribute ospf 100 metric 10000 100 255 1 1500
!
router ospf 100
redistribute eigrp 100 metric-type 1 subnets
network 3.3.3.3 0.0.0.0 area 0
network 34.1.1.0 0.0.0.255 area 0
distance 180 2.2.2.2 0.0.0.0


R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
ip address 24.1.1.4 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/3
ip address 34.1.1.4 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 100
network 4.4.4.4 0.0.0.0 area 0
network 24.1.1.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0


  1.0.0.0/32 is subnetted, 1 subnets
O E1     1.1.1.1 [110/30] via 34.1.1.3, 00:54:33, Ethernet0/3
                 [110/30] via 24.1.1.2, 01:22:45, Ethernet0/2
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/11] via 24.1.1.2, 01:29:12, Ethernet0/2
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/11] via 34.1.1.3, 01:26:23, Ethernet0/3
      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.4 is directly connected, Loopback0
      13.0.0.0/24 is subnetted, 1 subnets
O E1     13.13.13.0 [110/30] via 34.1.1.3, 00:54:33, Ethernet0/3
                    [110/30] via 24.1.1.2, 01:06:16, Ethernet0/2
      24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        24.1.1.0/24 is directly connected, Ethernet0/2
L        24.1.1.4/32 is directly connected, Ethernet0/2
      34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        34.1.1.0/24 is directly connected, Ethernet0/3
L        34.1.1.4/32 is directly connected, Ethernet0/3
      123.0.0.0/24 is subnetted, 1 subnets
O E1     123.1.1.0 [110/30] via 34.1.1.3, 00:54:33, Ethernet0/3
                   [110/30] via 24.1.1.2, 01:11:37, Ethernet0/2


最佳答案

查看完整内容

很简单的一道题, 不过在解之前 你是不是应该考虑下 路由环的问题。 随便弄一下就有路由环了。这种配置在工作中最好不要出现。
发表于 2017-3-16 12:19:39 | 显示全部楼层
很简单的一道题, 不过在解之前 你是不是应该考虑下 路由环的问题。  随便弄一下就有路由环了。这种配置在工作中最好不要出现。
沙发 2017-3-16 12:19:39 回复 收起回复
回复

使用道具 举报

 楼主| 发表于 2017-3-20 14:09:39 | 显示全部楼层
skylake 发表于 2017-3-20 11:35
很简单的一道题, 不过在解之前 你是不是应该考虑下 路由环的问题。  随便弄一下就有路由环了。这种配置在 ...

重分发这边学得不好 ,能否简单的说一下思路大神
板凳 2017-3-20 14:09:39 回复 收起回复
回复

使用道具 举报

 楼主| 发表于 2017-3-20 14:09:45 | 显示全部楼层
skylake 发表于 2017-3-20 11:35
很简单的一道题, 不过在解之前 你是不是应该考虑下 路由环的问题。  随便弄一下就有路由环了。这种配置在 ...

重分发这边学得不好 ,能否简单的说一下思路大神
地板 2017-3-20 14:09:45 回复 收起回复
回复

使用道具 举报

发表于 2017-3-21 11:48:34 | 显示全部楼层
r1 过来的路由, 在 r2,r3上 你shut down 某个口 就可能出现环。这个由于两个协议没有协商造成的,哪个协议先占据路由表, 谁就会直接冲到下一台路由器上,影响下个个路由器的判断。 基本这种问题都要配置 路由过滤来解决。另外你这题 题目交代的也不是很清楚。 有好几个问题 没看sho run 我也无法判断这个结果怎么得来的。
1. D EX     2.2.2.2 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      3.0.0.0/32 is subnetted, 1 subnets
D EX     3.3.3.3 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      4.0.0.0/32 is subnetted, 1 subnets
D EX     4.4.4.4 [170/307200] via 13.13.13.2, 00:26:27, Ethernet0/1
      13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
这几个路由的metric值怎么可能一样? 是不是 你做了什么配置。我看你接口下带宽延时根本就没配。
ospf :distance 180 3.3.3.3 0.0.0.0 这个是没写完么?
redistribute ospf 100 metric 1000 100 255 1 150 最后的150 是写错了么? 这个150 不会参与计算的.
5# 2017-3-21 11:48:34 回复 收起回复
回复

使用道具 举报

 楼主| 发表于 2017-3-21 18:42:27 | 显示全部楼层
skylake 发表于 2017-3-21 11:48
r1 过来的路由, 在 r2,r3上 你shut down 某个口 就可能出现环。这个由于两个协议没有协商造成的,哪个协议 ...

谢谢。我回去修改一下
6# 2017-3-21 18:42:27 回复 收起回复
回复

使用道具 举报

发表于 2017-3-23 17:08:40 | 显示全部楼层
我记得这个是可以使用路由泄露技术就可以搞定的,或者是修改metric值也可以搞定
7# 2017-3-23 17:08:40 回复 收起回复
回复

使用道具 举报

发表于 2017-3-24 22:24:42 | 显示全部楼层
,正确的做法是,R2,R3上把EIGRP在重分布E-O时进行打标,用什么打标怎么打标随自己的习惯,然后,R2和R3都过滤掉对方重分布进来的打标路由,这样就不会加表了。
8# 2017-3-24 22:24:42 回复 收起回复
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-5-12 08:22 , Processed in 0.115180 second(s), 27 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表