|
R2的配置
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set ccie esp-3des esp-sha-hmac
crypto ipsec profile cisco
set transform-set ccie
interface Tunnel2
bandwidth 1000
ip address 111.111.111.2 255.255.255.0
ip mtu 1400
ip nhrp authentication ccie123
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source Serial3/0
tunnel mode gre multipoint
tunnel protection ipsec profile cisco
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip nat inside
no shut
interface Serial3/0
ip address 12.1.1.2 255.255.255.0
ip nat outside
no shut
router ospf 110
network 111.111.111.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
ip route 0.0.0.0 0.0.0.0 12.1.1.1
ip nat inside source list 100 interface Serial3/0 overload
access-list 100 permit ip any any
R1配置
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shut
interface Serial3/0
ip address 12.1.1.1 255.255.255.0
no shut
interface Serial3/1
ip address 13.1.1.1 255.255.255.0
no shut
R3配置
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
crypto ipsec transform-set ccie esp-3des esp-sha-hmac
crypto ipsec profile cisco
set transform-set ccie
interface Tunnel3
bandwidth 1000
ip address 111.111.111.3 255.255.255.0
ip mtu 1400
ip nhrp authentication ccie123
ip nhrp map 111.111.111.2 12.1.1.2
ip nhrp map multicast 12.1.1.2
ip nhrp network-id 1
ip nhrp nhs 111.111.111.2
tunnel source Serial3/0
tunnel mode gre multipoint
tunnel protection ipsec profile cisco
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
no shut
interface Serial3/0
ip address 13.1.1.3 255.255.255.0
no shut
router ospf 110
network 111.111.111.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
ip route 0.0.0.0 0.0.0.0 13.1.1.1
|
|