- 积分
- 374
- 鸿鹄币
- 个
- 好评度
- 点
- 精华
- 最后登录
- 1970-1-1
- 阅读权限
- 30
- 听众
- 收听
初级工程师
  
|
1鸿鹄币
本帖最后由 Hamburg 于 2011-6-14 21:03 编辑
R1:
enable
conf t
hostname R1
!
no ip domain lookup
!
int lo0
ip add 1.1.1.1 255.255.255.0
exit
!
int s1/1
ip add 10.1.12.1 255.255.255.0
no shut
exit
!
line con 0
exec-timeout 0 0
logging s
exit
line vty 0 4
exec-timeout 0 0
logging s
exit
!
router eigrp 100
network 10.1.12.0 0.0.0.255
network 1.1.1.0 0.0.0.255
no auto-summary
end
R2:
enable
conf t
hostname R2
!
no ip domain lookup
!
int lo0
ip add 2.2.2.2 255.255.255.0
exit
!
int s1/1
ip add 10.1.12.2 255.255.255.0
no shut
exit
!
line con 0
exec-timeout 0 0
logging s
exit
line vty 0 4
exec-timeout 0 0
logging s
exit
!
router eigrp 100
network 10.1.12.0 0.0.0.255
network 2.2.2.0 0.0.0.255
no auto-summary
end
之后出现:
R1#
*Jun 14 19:24:37.167: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Jun 14 19:24:39.071: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
R1#
*Jun 14 19:24:40.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R1#
*Jun 14 19:25:00.619: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to
down
R2#
*Jun 14 19:25:10.931: %SYS-5-CONFIG_I: Configured from console by console
R2#
*Jun 14 19:25:11.391: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
R2#
*Jun 14 19:25:12.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R2#
*Jun 14 19:25:40.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
EIGRP实验基本配置是否已配置完成?邻居关系是否已经建立?是否已经可以show ip eigrp nei 查看邻居?
sh ip ei nei ,可是没有建立邻居关系。。。
R1#sh ip ei nei
IP-EIGRP neighbors for process 100
R1#
R2#sh ip ei nei
IP-EIGRP neighbors for process 100
R2#
sh ip route ei ,什么也没有。。。
sh ip pro ,看下面。。。有eigrp 100。。可是没有Routing Information Sources:这个的内容。。。
R1#sh ip pro
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
1.1.1.0/24
10.1.12.0/24
Routing Information Sources:
Gateway Distance Last Update
Distance: internal 90 external 170
R2#sh ip pro
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.2.2.0/24
10.1.12.0/24
Routing Information Sources:
Gateway Distance Last Update
Distance: internal 90 external 170
同样没有Routing Information Sources: 什么情况???
sh ip route ,看下面。。。
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
怎么没有直连的10.1.12.0网段???好烦啊。。。急了。。。
R1:ping 10.1.12.1 (R1上的s1/1,ping不通。。。)
R2:同样ping 10.1.12.2 自己的串口ping不通。。。
sh run
R1#sh run
Building configuration...
Current configuration : 1358 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 10.1.12.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface ATM3/0
no ip address
shutdown
no atm ilmi-keepalive
!
router eigrp 100
network 1.1.1.0 0.0.0.255
network 10.1.12.0 0.0.0.255
no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!
!
end
R2#sh run
Building configuration...
Current configuration : 1291 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 10.1.12.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
network 2.2.2.0 0.0.0.255
network 10.1.12.0 0.0.0.255
no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
logging synchronous
login
!
!
end
还要什么可以查看的吗?debug 什么命令吗???
What?Why?
还是要做认证???
真是郁闷。。。
是用SecureCRT 6.0这个模拟软件的。。。
追问:
为什么两台路由器的直连串口号不能一样???比如s1/1跟s1/1相连。。。
刚才把一个串口改掉了。。OK了。。谢谢啦,各位大哥!!!
|
最佳答案
查看完整内容
LZ是不是用dynamic,这个模拟器的拓扑是R1的s1/1连接R2的s1/0的,然后R2的S1/1连接R3的S1/0,以此类推
你用R1和R2的S1/1连接本身就是不同的,可以看看文件夹里面的拓扑图
不知道LZ是不是这问题
eigrp当然是不需要认证才能建立邻居咯~
|