成长值: 36730
|
1鸿鹄币
配置拓扑如图:
三台路由器的配置如下:
R1:
version 15.4
hostname R1
no ip domain lookup
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback11
ip address 10.1.2.1 255.255.255.0
!
interface Loopback12
ip address 10.1.3.1 255.255.255.0
!
interface Loopback13
ip address 10.1.4.1 255.255.255.0
interface Serial1/1
ip address 172.16.1.1 255.255.255.252
router eigrp 50
network 10.0.0.0
network 172.16.0.0
line con 0
exec-timeout 0 0
logging synchronous
R2:
version 15.4
hostname R2
no ip domain lookup
interface Ethernet0/0
ip address 131.131.1.1 255.255.0.0
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
interface Serial1/1
ip address 172.16.1.5 255.255.255.252
router eigrp 50
network 131.131.0.0
network 172.16.0.0
line con 0
exec-timeout 0 0
logging synchronous
R3:
version 15.4
hostname R3
no ip domain lookup
interface Loopback10
ip address 192.168.0.1 255.255.255.0
!
interface Loopback11
ip address 192.168.1.1 255.255.255.0
!
interface Loopback12
ip address 192.168.2.1 255.255.255.0
!
interface Loopback13
ip address 192.168.3.1 255.255.255.0
interface Serial1/0
ip address 172.16.1.6 255.255.255.252
router eigrp 50
network 172.16.0.0
network 192.168.0.0
line con 0
exec-timeout 0 0
logging synchronous
配置完成后当在R2上show ip route时显示如下:
10.0.0.0/24 is subnetted, 4 subnets
D 10.1.1.0 [90/2297856] via 172.16.1.1, 00:26:16, Serial1/0
D 10.1.2.0 [90/2297856] via 172.16.1.1, 00:26:16, Serial1/0
D 10.1.3.0 [90/2297856] via 172.16.1.1, 00:26:16, Serial1/0
D 10.1.4.0 [90/2297856] via 172.16.1.1, 00:26:16, Serial1/0
131.131.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 131.131.0.0/16 is directly connected, Ethernet0/0
L 131.131.1.1/32 is directly connected, Ethernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.1.0/30 is directly connected, Serial1/0
L 172.16.1.2/32 is directly connected, Serial1/0
C 172.16.1.4/30 is directly connected, Serial1/1
L 172.16.1.5/32 is directly connected, Serial1/1
D 192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:27:06, Serial1/1
问题:为什么10.0.0.0会显示明细路由,192.168.0.0只显示汇总路由,有什么影响吗?
|
-
最佳答案
查看完整内容
192.168.0.0/24不是滙總路由,僅是單一網段的路由,不包含192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24,R2 ping R3的Loopback11, Loopback12, Loopback13是無法通的。
因eigrp的network指令若省略了「EIGRP wild card bits」將視其所接網段為ABC網段。
因而若要R2 ping R3的Loopback11, Loopback12, Loopback13可以通,R3的指令
network 192.168.0.0
要改為
network 192.168.0.0 0.0.255.255
或
netw ...
|