设为首页收藏本站language→→ 语言切换

鸿鹄论坛

 找回密码
 论坛注册

QQ登录

先注册再绑定QQ

查看: 2418|回复: 15
收起左侧

[RS] 只有1个公网IP地址时,使用VRRP技术实现设备冗余备份

[复制链接]
发表于 2018-6-4 15:52:11 | 显示全部楼层 |阅读模式

vrrp

vrrp

R1#sh running-config
Building configuration...

Current configuration : 1760 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback1
ip address 123.123.123.123 255.255.255.255
!
interface FastEthernet0/0
ip address 123.1.1.1 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 123.1.1.254
vrrp 1 priority 200
!
interface FastEthernet1/0
ip address 15.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
!
interface FastEthernet3/1
!         
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
no ip address
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 15.1.1.0 0.0.0.255 area 0
network 33.3.3.3 0.0.0.0 area 0
network 123.1.1.252 0.0.0.3 area 0
default-information originate
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 123.1.1.253
ip route 33.3.3.3 255.255.255.255 123.1.1.253
!
!
!         
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login   
!         
!
end

R2#sh run
*Mar  1 00:57:52.119: %SYS-5-CONFIG_I: Configured from console by console
R2#sh run
Building configuration...

Current configuration : 1807 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 123.123.123.123 255.255.255.255
!
interface FastEthernet0/0
ip address 123.1.1.2 255.255.255.0
shutdown
duplex auto
speed auto
vrrp 1 ip 123.1.1.254
!
interface FastEthernet1/0
ip address 24.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!         
interface FastEthernet3/12
!
interface FastEthernet3/13
!
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
no ip address
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 24.1.1.0 0.0.0.255 area 0
network 33.3.3.3 0.0.0.0 area 0
network 123.1.1.252 0.0.0.3 area 0
default-information originate
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 123.1.1.253
ip route 33.3.3.3 255.255.255.255 123.1.1.253
!
!
!

R3#sh run
Building configuration...

Current configuration : 1540 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 33.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 123.1.1.253 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!         
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
no ip address
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 3.3.3.254
ip route 0.0.0.0 0.0.0.0 123.1.1.254
ip route 3.3.3.3 255.255.255.255 3.3.3.1

R4#sh run
Building configuration...

Current configuration : 1085 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 24.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 24.1.1.0 0.0.0.255 area 0
network 45.1.1.0 0.0.0.255 area 0
!         

R5#sh run
Building configuration...

Current configuration : 1085 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 15.1.1.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 15.1.1.0 0.0.0.255 area 0
network 45.1.1.0 0.0.0.255 area 0
!         

 楼主| 发表于 2018-6-4 15:58:49 | 显示全部楼层
欢迎添加公众号,关注更多内容多交流学习
“网络知识和Python学习分享“     
沙发 2018-6-4 15:58:49 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-4 16:16:59 | 显示全部楼层
卖弄什么啊,有几个公网地址和VRRP有关系吗?
板凳 2018-6-4 16:16:59 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-6-4 16:23:08 | 显示全部楼层
ackca 发表于 2018-6-4 16:16
卖弄什么啊,有几个公网地址和VRRP有关系吗?

今天看论坛想到的问题,如果运营商只给你一个/30位的地址,其中一个是网关,那你只有一个地址可以配置,公司出口两个路由器,vrrp不是很好的解决方法嘛?
地板 2018-6-4 16:23:08 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-4 18:45:58 | 显示全部楼层
少时诵诗书所所所所所所所所
6# 2018-6-4 18:45:58 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-4 18:46:05 | 显示全部楼层
等待     
7# 2018-6-4 18:46:05 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-4 20:17:49 | 显示全部楼层
于利祥 发表于 2018-6-4 16:23
今天看论坛想到的问题,如果运营商只给你一个/30位的地址,其中一个是网关,那你只有一个地址可以配置, ...

自己好好学习vrrp是做什么的,别在这卖弄,和几个ip地址有关系吗?多给几个还不能用了?给你3个ip地址,有两个路由器,怎么分?1台上1个,另一个上2个?不怕异步路由?
9# 2018-6-4 20:17:49 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-6-5 09:08:48 | 显示全部楼层
ackca 发表于 2018-6-4 20:17
自己好好学习vrrp是做什么的,别在这卖弄,和几个ip地址有关系吗?多给几个还不能用了?给你3个ip地址, ...

我说的只有1个地址的情况,那请大神指点一下1个公网地址时怎么使用。
10# 2018-6-5 09:08:48 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-5 10:37:58 | 显示全部楼层
于利祥 发表于 2018-6-5 09:08
我说的只有1个地址的情况,那请大神指点一下1个公网地址时怎么使用。

好好学vrrp去,别在这卖弄,vrrp和公网地址没有半点关系
11# 2018-6-5 10:37:58 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-6-5 12:25:01 | 显示全部楼层
ackca 发表于 2018-6-5 10:37
好好学vrrp去,别在这卖弄,vrrp和公网地址没有半点关系

这本来就是讨论技术的论坛,什么叫卖弄。我跟你说一下真实需求(数据中心从移动运营商拉了一个10GE的带宽,移动运营商只有一条光纤链路进来,数据中心有在两个机房的两台出口路由器,如果直接接一台路由器会出现单点故障,领导需要一根光纤接到两台路由器实现冗余。)有不对就提出来,一直抓着vrrp干嘛。
12# 2018-6-5 12:25:01 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-5 12:54:14 | 显示全部楼层
于利祥 发表于 2018-6-5 12:25
这本来就是讨论技术的论坛,什么叫卖弄。我跟你说一下真实需求(数据中心从移动运营商拉了一个10GE的带宽 ...

一条线怎么接到两个路由器上?用VRRP能没有单点故障?
13# 2018-6-5 12:54:14 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-11 21:59:41 来自手机 | 显示全部楼层
vrrp确实和几个公网IP没有直接关系,但说人家卖弄也不妥
14# 2018-6-11 21:59:41 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2018-6-14 22:39:38 | 显示全部楼层
于利祥 发表于 2018-6-4 16:23
今天看论坛想到的问题,如果运营商只给你一个/30位的地址,其中一个是网关,那你只有一个地址可以配置, ...

FHRP都可以
15# 2018-6-14 22:39:38 回复 收起回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-1-24 08:48 , Processed in 0.070324 second(s), 13 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表