|
发表于 2015-12-30 11:10:06
|
显示全部楼层
这是我当年做的实验笔记。好几年前的了,也不知道有没有错。贴出来给你看看吧。
-------------------------------------------------------------------------------------------------------
1.如图(附件)所示,在机架上按照图示的PVC配置frame-relay。R1,R4,R5串口IP地址1.1.145.X/24。使用R2和R3当做帧中继交换机,在R2和R3之间使用E0口作为tunnel。完成6条PVC的full mesh帧中继链路
配置:
R4#show run
Building configuration...
Current configuration : 1244 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 1.1.145.4 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 1.1.145.1 401 broadcast
frame-relay map ip 1.1.145.5 405 broadcast
frame-relay map ip 1.1.145.4 401 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
end
R1#show run
Building configuration...
Current configuration : 1244 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 1.1.145.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 1.1.145.5 105 broadcast
frame-relay map ip 1.1.145.4 104 broadcast
frame-relay map ip 1.1.145.1 104 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
end
R2#show run
Building configuration...
Current configuration : 1528 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
frame-relay switching
!
archive
log config
hidekeys
!
interface Tunnel0
no ip address
tunnel source 23.1.1.2
tunnel destination 23.1.1.3
!
interface FastEthernet0/0
ip address 23.1.1.2 255.255.255.0
duplex half
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 401 interface Serial1/1 104
frame-relay route 405 interface Tunnel0 100
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 104 interface Serial1/0 401
frame-relay route 105 interface Tunnel0 200
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
end
R3#show run
Building configuration...
Current configuration : 1307 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
frame-relay switching
!
archive
log config
hidekeys
!
interface Tunnel0
no ip address
tunnel source FastEthernet0/0
tunnel destination 23.1.1.2
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 501 interface Tunnel0 200
frame-relay route 504 interface Tunnel0 100
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
end
R5#show run
Building configuration...
Current configuration : 1313 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.5.5 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 1.1.145.5 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 1.1.145.4 504 broadcast
frame-relay map ip 1.1.145.1 501 broadcast
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
2.R1R4R5上分别指定LO0地址为10.10.X.X/24,在三台路由器上运行RIPv2,观察路由状况
现象:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.145.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 3 subnets
C 10.10.1.0 is directly connected, Loopback0
R 10.10.4.0 [120/1] via 1.1.145.4, 00:00:15, Serial1/0
R 10.10.5.0 [120/1] via 1.1.145.5, 00:00:17, Serial1/0
R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.145.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 3 subnets
R 10.10.1.0 [120/1] via 1.1.145.1, 00:00:18, Serial1/0
C 10.10.4.0 is directly connected, Loopback0
R 10.10.5.0 [120/1] via 1.1.145.5, 00:00:25, Serial1/0
R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.145.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 3 subnets
R 10.10.1.0 [120/1] via 1.1.145.1, 00:00:12, Serial1/0
R 10.10.4.0 [120/1] via 1.1.145.4, 00:00:17, Serial1/0
C 10.10.5.0 is directly connected, Loopback0
3.将路由器端的inverse ARP关闭,通过手工添加frame-relay map的方式实现fullmesh frame-relay。如果在添加MAP时不使用broadcast参数,观察RIP的路由能否接收到?
要点:不能,加入broadcast参数的目的是为了在帧中继环境中传递组播和广播。而RIPv2采用的是组播224.0.0.9,如果环境中不允许传递组播,那么将无法传递RIP路由
现象:
R5(config-if)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.145.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.5.0 is directly connected, Loopback0
4.在R4端删除405的PVC MAP,在R5端删除504的PVC MAP,要求实现FR的fullmesh,如何实现?这时R4R5两个spoke端能否收到对方的路由?为什么?
要点:在R4上写frame-relay map ip 1.1.145.5 401 br;
在R5上写frame-relay map ip 1.1.145.4 501 br。
rip协议在帧中继环境中默认是关闭水平分割的。
5.将RIP删除,使用EIGRP,观察R4R5两个spoke端能否收到对端的路由?为什么?如果不能收到,如何解决问题?
要点:不行,因为eigrp协议在帧中继环境下默认是开启水平分割的。应该在R1-S1/0下关闭水平分割。命令为:
(config-if)#no ip split-horizon eigrp 90
|
-
沙发
2015-12-30 11:10:06
回复(0)
收起回复
|