|
发表于 2015-8-22 14:54:48
|
显示全部楼层
我不知道你怎么配的。 我试了一下,应该没有问题啊。
简单的R1和R2串口相连。 R1上起4个loopback口:
------ R1 configuration --------
interface Serial3/0
ip address 10.1.1.1 255.255.255.0
interface Loopback8
ip address 172.16.8.1 255.255.255.0
!
interface Loopback9
ip address 172.16.9.1 255.255.255.0
!
interface Loopback10
ip address 172.16.10.1 255.255.255.0
!
interface Loopback11
ip address 172.16.11.1 255.255.255.0
!
router rip
version 2
network 10.0.0.0
network 172.16.0.0
no auto-summary
-------- R2 configuration ----------
!
interface Serial3/0
ip address 10.1.1.2 255.255.255.0
!
router rip
version 2
network 2.0.0.0
network 10.0.0.0
no auto-summary
======= 汇总之前 =========
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 10.1.1.2, 00:00:26, Serial3/0
172.16.0.0/24 is subnetted, 4 subnets
C 172.16.8.0 is directly connected, Loopback8
C 172.16.9.0 is directly connected, Loopback9
C 172.16.10.0 is directly connected, Loopback10
C 172.16.11.0 is directly connected, Loopback11
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial3/0
R1#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24
[1] via 10.1.1.2, 00:00:04, Serial3/0
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial3/0
172.16.0.0/16 auto-summary
172.16.8.0/24 directly connected, Loopback8
172.16.9.0/24 directly connected, Loopback9
172.16.10.0/24 directly connected, Loopback10
172.16.11.0/24 directly connected, Loopback11
R1#
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.8.0 [120/1] via 10.1.1.1, 00:00:01, Serial3/0
R 172.16.9.0 [120/1] via 10.1.1.1, 00:00:01, Serial3/0
R 172.16.10.0 [120/1] via 10.1.1.1, 00:00:01, Serial3/0
R 172.16.11.0 [120/1] via 10.1.1.1, 00:00:01, Serial3/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial3/0
R2#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24 directly connected, Loopback0
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial3/0
172.16.0.0/16 auto-summary
172.16.8.0/24
[1] via 10.1.1.1, 00:00:09, Serial3/0
172.16.9.0/24
[1] via 10.1.1.1, 00:00:09, Serial3/0
172.16.10.0/24
[1] via 10.1.1.1, 00:00:09, Serial3/0
172.16.11.0/24
[1] via 10.1.1.1, 00:00:09, Serial3/0
R2#
==========在R1的serial 3/0接口上做手动汇总 =============
R1#sh running-config interface serial 3/0
Building configuration...
Current configuration : 135 bytes
!
interface Serial3/0
ip address 10.1.1.1 255.255.255.0
ip summary-address rip 172.16.8.0 255.255.252.0
serial restart-delay 0
end
========手动汇总之后 ============
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 10.1.1.2, 00:00:11, Serial3/0
172.16.0.0/24 is subnetted, 4 subnets
C 172.16.8.0 is directly connected, Loopback8
C 172.16.9.0 is directly connected, Loopback9
C 172.16.10.0 is directly connected, Loopback10
C 172.16.11.0 is directly connected, Loopback11
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial3/0
R1#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24
[1] via 10.1.1.2, 00:00:21, Serial3/0
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial3/0
172.16.0.0/16 auto-summary
172.16.8.0/22 int-summary
172.16.8.0/24 directly connected, Loopback8
172.16.9.0/24 directly connected, Loopback9
172.16.10.0/24 directly connected, Loopback10
172.16.11.0/24 directly connected, Loopback11
R1#
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
172.16.0.0/22 is subnetted, 1 subnets
R 172.16.8.0 [120/1] via 10.1.1.1, 00:00:26, Serial3/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial3/0
R2#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24 directly connected, Loopback0
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial3/0
172.16.0.0/16 auto-summary
172.16.8.0/22
[1] via 10.1.1.1, 00:00:06, Serial3/0
R2#
========= 结论 ==========
1) 汇总之后,在本路由器上是看不到这个汇总路由在路由表里的。 汇总路由只存在于RIP database里。 而且是汇总路由会更新给邻居;
2) 邻居会收到汇总路由,然后删去明细路由, 并且把汇总路由放入database以及路由表里。
===== 补充 ======
自我感觉这篇文章对RIP的汇总总结的很好:
http://www.chinabaike.com/t/35933/2014/0624/2550329.html
|
-
RIP 汇总拓扑图
9#
2015-8-22 14:54:48
回复(0)
收起回复
|