设为首页收藏本站language→→ 语言切换

鸿鹄论坛

 找回密码
 论坛注册

QQ登录

先注册再绑定QQ

查看: 2344|回复: 2
收起左侧

[文档] 单臂路由实验报告拓扑图+自刷代码+实验分析+文档

[复制链接]
发表于 2014-8-19 20:02:16 | 显示全部楼层 |阅读模式
QQ图片20140819195508.jpg
一、 实验目标
(1) 熟悉层次化配置方法
(2) 掌握单臂路由的配置命令
(3) 实现全网的连通性,包括交换机的网管VLAN
(4) 分析PC1PC2的通信过程
二、 实验步骤
1、 基本配置:
   R1(config)#no ip do
   R1(config)#no ip domain-lookup
   R1(config)#line console 0
   R1(config-line)#logging sy
   R1(config-line)#logging synchronous
   R1(config-line)#exec
   R1(config-line)#exec-t
   R1(config-line)#exec-timeout 0 0
   R1(config-line)#no login
   R1(config-line)#exit
   R1(config)#line vty 0 4
   R1(config-line)#no login
   R1(config-line)#end
刷配置:
conf t
no ip domain-lookup
line console 0
logging synchronous
exec-timeout 0 0
no login
exit
line vty 0 4
no login
end
   SW2基本配置和R1一样。
2、 二层链路及VLAN配置和调试(VLANACCESSTRUNK
    SW2(config)#int f0/1
    SW2(config-if)#switchport trunk encapsulation dot1q
    SW2(config-if)#switchport mode trunk
    *Mar  1 00:16:58.923: %DTP-5-TRUNKPORTON: Port Fa0/1 has become dot1q trunk
    SW2(config-if)#switchport trunk allowed vlan all
    SW2(config-if)#no shutdown
    SW2(config-if)#exit
    SW2(config)#int f0/2
    SW2(config-if)#switchport mode access
    SW2(config-if)#switchport access vlan 11
    SW2(config-if)#no shutdown
    SW2(config-if)#exit
    SW2(config)#int f0/3
    SW2(config-if)#switchport mode access
    SW2(config-if)#switchport access vlan 21
    SW2(config-if)#no shutdown
SW2(config-if)#exit
刷:
Conf t
No ip routing
end
Vlan database
Vlan 11
Vlan 21
Exit
Conf t
int f0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
exit
int f0/2
switchport mode access
switchport access vlan 11
no shutdown
exit
int f0/3
switchport mode access
switchport access vlan 21
no shutdown
exit
3、 三层接口配置和调试
   R1(config)#int f0/0.1
   R1(config-subif)#encapsulation dot1Q 11
   R1(config-subif)#ip address 192.168.11.11 255.255.255.0
   R1(config-subif)#no shutdown
   R1(config-subif)#exit
   R1(config)#exit
   R1(config)#int f0/0.2
   R1(config-subif)#encapsulation dot1Q 21
   R1(config-subif)#ip address 192.168.21.11 255.255.255.0
   R1(config-subif)#no shutdown
   R1(config-subif)#exit
   R1(config)#exit
刷配置
Conf t
Int f0/0
No sh
exit
int f0/0.1
encapsulation dot1Q 11
ip address 192.168.11.11 255.255.255.0
no shutdown
Exit
int f0/0.2
encapsulation dot1Q 21
ip address 192.168.21.11 255.255.255.0
no shutdown
exit
Exit
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  up                    up      
FastEthernet0/0.1          192.168.11.11   YES manual up                    up      
FastEthernet0/0.2          192.168.21.11   YES manual up                    up
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C    192.168.11.0/24 is directly connected, FastEthernet0/0.1
C    192.168.21.0/24 is directly connected, FastEthernet0/0.2
4、全网连通性测试:
VPCS 1 >ping 192.168.11.11
192.168.11.11 icmp_seq=1 time=47.000 ms
192.168.11.11 icmp_seq=2 time=47.000 ms
192.168.11.11 icmp_seq=3 time=47.000 ms
192.168.11.11 icmp_seq=4 time=47.000 ms
192.168.11.11 icmp_seq=5 time=47.000 ms
VPCS 1 >ping 192.168.11.10
192.168.11.10 icmp_seq=1 time=0.001 ms
192.168.11.10 icmp_seq=2 time=0.001 ms
192.168.11.10 icmp_seq=3 time=0.001 ms
192.168.11.10 icmp_seq=4 time=0.001 ms
192.168.11.10 icmp_seq=5 time=0.001 ms
VPCS 1 >ping 192.168.21.11
192.168.21.11 icmp_seq=1 time=46.000 ms
192.168.21.11 icmp_seq=2 time=47.000 ms
192.168.21.11 icmp_seq=3 time=47.000 ms
192.168.21.11 icmp_seq=4 time=47.000 ms
192.168.21.11 icmp_seq=5 time=47.000 ms
VPCS 1 >ping 192.168.21.10
192.168.21.10 icmp_seq=1 time=78.000 ms
192.168.21.10 icmp_seq=2 time=78.000 ms
192.168.21.10 icmp_seq=3 time=78.000 ms
192.168.21.10 icmp_seq=4 time=79.000 ms
192.168.21.10 icmp_seq=5 time=78.000 ms
VPCS 2 >ping 192.168.11.11
192.168.11.11 icmp_seq=1 time=31.000 ms
192.168.11.11 icmp_seq=2 time=46.000 ms
192.168.11.11 icmp_seq=3 time=47.000 ms
192.168.11.11 icmp_seq=4 time=47.000 ms
192.168.11.11 icmp_seq=5 time=47.000 ms
VPCS 2 >ping 192.168.11.10
192.168.11.10 icmp_seq=1 time=78.000 ms
192.168.11.10 icmp_seq=2 time=78.000 ms
192.168.11.10 icmp_seq=3 time=78.000 ms
192.168.11.10 icmp_seq=4 time=78.000 ms
192.168.11.10 icmp_seq=5 time=78.000 ms
VPCS 2 >ping 192.168.21.11
192.168.21.11 icmp_seq=1 time=47.000 ms
192.168.21.11 icmp_seq=2 time=47.000 ms
192.168.21.11 icmp_seq=3 time=46.000 ms
192.168.21.11 icmp_seq=4 time=47.000 ms
192.168.21.11 icmp_seq=5 time=47.000 ms
VPCS 2 >ping 192.168.21.10
192.168.21.10 icmp_seq=1 time=0.001 ms
192.168.21.10 icmp_seq=2 time=0.001 ms
192.168.21.10 icmp_seq=3 time=0.001 ms
192.168.21.10 icmp_seq=4 time=0.001 ms
192.168.21.10 icmp_seq=5 time=0.001 ms
4、 跨广播域数据流分析:
PC1 ping PC2之间的数据流分析
首先,PC1先判断自己的IPPC2IP是否属于同一网段,发现不是,确定把数据包发给默认网关;封装好三层数据之后,查找自己的ARP表,看有没有网关的MAC地址,发现没有,发ARP请求。
交换机收到ARP请求数据帧,记录对应的MAC地址和端口号,然后广播出去,到了路由器的F0/0接口,路由器接到先核对二层地址,发现是自己的,拆掉二层地址,发给上层进程。填上自己的MAC地址,以单播的形式发回给PC1,PC1收到后,把默认网关的MAC地址加入ARP地址表。
PC1重新发送数据帧,到了路由器,脱去VLAN11的标,查找路由表,找到对应直连路由,转发到F0/0.2接口,F0/0.2发送ARP请求PC2MAC地址,PC2回复请求,交换机记录PC2MAC地址和对应端口号。F0/0.2接口重新封装PC1的数据包,重新打上VLAN21的标发出去,PC2收到回复,原路返回。
5、 网关的作用?什么情况PC需要配置网关?
网关是连接不同VLAN的通信接口,通过网关,不同VLAN的用户可以互相访问。PC机需要访问外网的时候就要配置网关。
三、 实验总结
1、 单臂路由,一个路由的一个接口接通多个VLAN,该接口要和交换机相连,要封装TRUNK口协议。
2、 路由器接口默认关闭,要打开相应的接口。
3、 子接口的MAC地址是从总接口里分出来的两个MAC地址,可以认为是两个不同的地址。
4、 网关的作用是脱去原VLAN的标,打上新VLAN的标。

20140819单臂路由.doc

31.47 KB, 下载次数: 10, 下载积分: 鸿鹄币 -1 个

发表于 2014-8-28 09:04:25 | 显示全部楼层
好东西谢谢楼主分享
沙发 2014-8-28 09:04:25 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2016-8-11 16:35:07 | 显示全部楼层
顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶
板凳 2016-8-11 16:35:07 回复 收起回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-1-25 08:24 , Processed in 0.065411 second(s), 15 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表