DMVPN HUB在和Spoke建立OSPF邻居后,收不到Spoke 的Hello包直到超时.....HUB超时后又能收到Spoke的Hello包,又建立邻居,然后又超时,然后又建立邻居,,然后又超时,一直循环下去.............这不科学啊
IPsec配用上去
R1是HUB,R2.R3是Spoke
配置:
R1
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
ip address 172.168.1.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp redirect
ip ospf network broadcast
ip ospf priority 255
tunnel source FastEthernet1/0
tunnel mode gre multipoint
tunnel key 123456
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
ip address 180.1.1.2 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 172.168.1.0 0.0.0.255 area 0
!
R2
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel1
ip address 172.168.1.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map 172.168.1.1 180.1.1.2
ip nhrp network-id 10
ip nhrp nhs 172.168.1.1
ip nhrp shortcut
ip ospf network broadcast
tunnel source FastEthernet1/0
tunnel mode gre multipoint
tunnel key 123456
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
ip address 181.1.1.2 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 172.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 181.1.1.1