CE1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 1.1.1.1 0.0.0.0
network 192.168.1.0 0.0.0.3
no auto-summary
PE1
ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding vpna
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
mpls ip
!
router eigrp 10 10
network 192.168.1.0 0.0.0.3
no auto-summary
!
address-family ipv4 vrf vpna
redistribute bgp 100 metric 10000 1 255 1 1500 10
network 192.168.1.0
no auto-summary
autonomous-system 10
exit-address-family
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
!
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
redistribute eigrp 10
no synchronization
exit-address-family
P
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.5 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
mpls ip
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 0
PE2
ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.6 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding vpna
ip address 192.168.2.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 10 10
network 192.168.2.0 0.0.0.3
no auto-summary
!
address-family ipv4 vrf vpna
redistribute bgp 100 metric 10000 1 255 1 1500 10
network 192.168.2.0
no auto-summary
autonomous-system 10
exit-address-family
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.1.4 0.0.0.3 area 0
!
router bgp 100
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
redistribute eigrp 10
no synchronization
exit-address-family
CE2
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 10
network 5.5.5.5 0.0.0.0
network 192.168.2.0 0.0.0.3
auto-summary