Router1:
!
interface FastEthernet1/0
no ip address
duplex half
ipv6 address 2000::1/64
ipv6 rip cisco enable
!
interface FastEthernet2/0
no ip address
duplex half
ipv6 address 1000::1/64
ipv6 rip cisco enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router rip cisco
poison-reverse
!
!
!
Router2:
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 2000::2/64
ipv6 rip cisco enable
!
interface FastEthernet1/1
ip address 202.12.1.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 202.12.1.0
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router rip cisco
poison-reverse
!
ipv6 nat v4v6 source 192.168.1.2 3000::1
ipv6 nat v6v4 source 1000::2 202.12.1.100
ipv6 nat prefix 3000::/96
!
!
!
Router3:
!
interface FastEthernet1/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 202.12.1.3 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 192.168.1.0
network 202.12.1.0
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!