设为首页收藏本站language 语言切换
查看: 2615|回复: 1
收起左侧

[原创] 在IPv6 中部署6to4 Tunnel

[复制链接]
发表于 2013-2-28 14:51:04 | 显示全部楼层 |阅读模式
实验拓扑:
IPv6 6to4 Tunnel.png

实验步骤:

R1:
R1#show run
Building configuration...
Current configuration : 1057 bytes
!
! Last configuration change at 14:41:31 UTC Thu Feb 28 2013
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip cef
ipv6 unicast-routing
ipv6 multicast rpf use-bgp
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2002:202:202:1::1/64
ipv6 enable
ipv6 rip a enable
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2002:202:202:12::1/64
ipv6 enable
ipv6 rip a enable
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router rip a
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end


R2:
R2#show run
*Feb 28 14:41:36.599: %SYS-5-CONFIG_I: Configured from console by console
R2#show run
Building configuration...
Current configuration : 1380 bytes
!
! Last configuration change at 14:41:36 UTC Thu Feb 28 2013
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip cef
ipv6 unicast-routing
ipv6 multicast rpf use-bgp
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ipv6 address 2002:202:202:2::2/64
ipv6 enable
ipv6 rip a enable
!
interface Tunnel0
no ip address
no ip redirects
ipv6 unnumbered Loopback0
ipv6 enable
tunnel source 2.2.2.2
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2002:202:202:12::2/64
ipv6 enable
ipv6 rip a enable
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
speed auto
duplex auto
!
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 23.1.1.2 0.0.0.0
eigrp router-id 2.2.2.2
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2002::/16 Tunnel0
ipv6 router rip a
redistribute static metric 2
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!         
end


R3:
R3#show run
Building configuration...
*Feb 28 14:41:40.019: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 957 bytes
!
! Last configuration change at 14:41:40 UTC Thu Feb 28 2013
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip cef
ipv6 multicast rpf use-bgp
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
speed auto
duplex auto
!
!
router eigrp 1
network 23.0.0.0
network 34.0.0.0
eigrp router-id 3.3.3.3
!
ip forward-protocol nd
!         
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!         
!
end

R4:
R4#show run
Building configuration...
Current configuration : 1386 bytes
!
! Last configuration change at 14:41:43 UTC Thu Feb 28 2013
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip cef
ipv6 unicast-routing
ipv6 multicast rpf use-bgp
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ipv6 address 2002:404:404:4::4/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface Tunnel0
no ip address
no ip redirects
ipv6 unnumbered Loopback0
ipv6 enable
tunnel source 4.4.4.4
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
speed auto
duplex auto
ipv6 address 2002:404:404:45::4/64
ipv6 enable
ipv6 ospf 1 area 0
!
!
router eigrp 1
network 4.0.0.0
network 34.0.0.0
eigrp router-id 4.4.4.4
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2002::/16 Tunnel0
ipv6 router ospf 1
router-id 4.4.4.4
redistribute static metric 2
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!         
!
end


R5:
R5#show run
Building configuration...
Current configuration : 1079 bytes
!
! Last configuration change at 14:31:21 UTC Thu Feb 28 2013
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
--More--
*Feb 28 14:43:21.923: %OSPFv3-4-ERRRCV: OSPFv3-1-IPv6 Received invalid packet: Bad Checksum from FE80::C803:7FF:FE8C:6, FastEthernet0/0
no ip domain lookup
ip domain name lab.local
ip cef
ipv6 unicast-routing
ipv6 multicast rpf use-bgp
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2002:404:404:5::5/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2002:404:404:45::5/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 5.5.5.5
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

评分

参与人数 1鸿鹄币 +5 威望 +1 收起 理由
yg4638 + 5 + 1 很给力!

查看全部评分

发表于 2016-3-18 11:05:02 | 显示全部楼层
谢谢共享资料
沙发 2016-3-18 11:05:02 回复 收起回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-4-26 21:46 , Processed in 0.168636 second(s), 30 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表