设为首页收藏本站language 语言切换
查看: 3298|回复: 22
收起左侧

[已解决] eigrp ping不通

  [复制链接]
发表于 2013-1-10 10:33:25 | 显示全部楼层 |阅读模式
本帖最后由 chsense 于 2013-1-10 12:31 编辑

拓扑见附件图!
R1:
!
interface Ethernet0/0
ip address 172.46.0.1 255.255.255.252
half-duplex

R2:
R2#sh run
Building configuration...

Current configuration : 1161 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.10.1 255.255.255.248
!
interface Loopback1
ip address 192.168.100.9 255.255.255.252
!
interface Ethernet0/0
ip address 172.46.0.2 255.255.255.252
half-duplex
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
ip address 172.16.0.5 255.255.255.252
half-duplex
!
router eigrp 100
network 172.16.0.0
network 172.46.0.0
network 192.168.10.0
network 192.168.100.0
no auto-summary
!
no ip http server
no ip http secure-server
ip classless
ip default-network 172.46.0.0
ip route 0.0.0.0 0.0.0.0 172.46.0.1
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end


R3:
R3#sh run
Building configuration...

Current configuration : 1063 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.10.17 255.255.255.248
!
interface Loopback1
ip address 192.168.100.25 255.255.255.248
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
ip address 172.16.0.6 255.255.255.252
half-duplex
!
router eigrp 100
network 172.16.0.0
network 192.168.10.0
network 192.168.100.0
no auto-summary
!
no ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

===================================
R2 的默认路由已经通告出去了。R2也添加了一笔静态路由 。R3也学到了默认路由 。
为何就是不能 ping 172.46.0.1  ? 也就是说在R3上 : ping R1 e0/0 的ip 失败!

我这是在GNS3上做的测试!
请指点一下!马上就要去考试了,很着急,还没弄明白呢。谢谢


拓扑

拓扑
 楼主| 发表于 2013-1-10 10:37:21 | 显示全部楼层
模拟实验EIGRP ,也是这样配置的,为何就能ping 198.0.18.5 ? [ 就是ping ISP的ip ]
沙发 2013-1-10 10:37:21 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-1-10 10:48:39 | 显示全部楼层
再问一下,NA 考试中EIGRP这一题,所有router之间可以互相ping接口ip地址就够了吗?
板凳 2013-1-10 10:48:39 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:12:20 | 显示全部楼层
R2与R1是直连的,他们之间ping通不需要任何其他协议只需要ICMP能够到达就行了,也就是说你直连都不通,好好检查下。还有你那个下发默认路由有问题。Ip Default-networ 下发默认路由 必须路由表里面有这条路由才能下发,你现在路由表里面只有172.46.0.0/30.并没有172.46.0.0/16.所以要想下发默认路由还需要手动写一条静态172.16.0.0 255.255.0.0 null 0 这样才有效果
地板 2013-1-10 11:12:20 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:15:59 | 显示全部楼层
太多没看,R1到R3有路由么
5# 2013-1-10 11:15:59 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-1-10 11:22:48 | 显示全部楼层
R2#ping 172.46.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.46.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/33/44 ms
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.46.0.1 to network 0.0.0.0

     192.168.10.0/29 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, Loopback0
D       192.168.10.16 [90/409600] via 172.16.0.6, 00:57:59, Ethernet0/3
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.4 is directly connected, Ethernet0/3
*   172.46.0.0/30 is subnetted, 1 subnets
C*      172.46.0.0 is directly connected, Ethernet0/0
     192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.100.8/30 is directly connected, Loopback1
D       192.168.100.24/29 [90/409600] via 172.16.0.6, 00:58:01, Ethernet0/3
S*   0.0.0.0/0 [1/0] via 172.46.0.1

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.0.5 to network 172.46.0.0

     192.168.10.0/29 is subnetted, 2 subnets
D       192.168.10.0 [90/409600] via 172.16.0.5, 00:59:31, Ethernet0/3
C       192.168.10.16 is directly connected, Loopback0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.4 is directly connected, Ethernet0/3
     172.46.0.0/30 is subnetted, 1 subnets
D*      172.46.0.0 [90/307200] via 172.16.0.5, 00:59:31, Ethernet0/3
     192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
D       192.168.100.8/30 [90/409600] via 172.16.0.5, 00:59:33, Ethernet0/3
C       192.168.100.24/29 is directly connected, Loopback1


6# 2013-1-10 11:22:48 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:27:28 | 显示全部楼层
时钟频率有改过吗?
7# 2013-1-10 11:27:28 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:27:39 | 显示全部楼层
时钟频率有改过吗?
8# 2013-1-10 11:27:39 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:27:49 | 显示全部楼层
时钟频率有改过吗?
9# 2013-1-10 11:27:49 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:29:00 | 显示全部楼层
chsense 发表于 2013-1-10 11:22
R2#ping 172.46.0.1

Type escape sequence to abort.

你是不是用的Pt
10# 2013-1-10 11:29:00 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:29:09 | 显示全部楼层
chsense 发表于 2013-1-10 11:22
R2#ping 172.46.0.1

Type escape sequence to abort.

你是不是用的Pt
11# 2013-1-10 11:29:09 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:32:32 | 显示全部楼层
chsense 发表于 2013-1-10 11:22
R2#ping 172.46.0.1

Type escape sequence to abort.

这明显有问题。EIGRP下发默认路由的3要素就是:1以主类形式在进程里面宣告2以主类形式ip default-network3路由表里面有这条主类的路由
12# 2013-1-10 11:32:32 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-1-10 11:33:42 | 显示全部楼层
GNS 3
没修改clock rate呢
13# 2013-1-10 11:33:42 回复 收起回复
回复 支持 反对

使用道具 举报

发表于 2013-1-10 11:35:54 | 显示全部楼层
不错不错,支持顶个
14# 2013-1-10 11:35:54 回复 收起回复
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-1-10 11:41:27 | 显示全部楼层
本帖最后由 chsense 于 2013-1-10 11:44 编辑
84983251 发表于 2013-1-10 11:32
这明显有问题。EIGRP下发默认路由的3要素就是:1以主类形式在进程里面宣告2以主类形式ip default-network ...


你再帮忙看看.
sh run
router eigrp 100
network 172.16.0.0
network 172.46.0.0
network 192.168.10.0
network 192.168.100.0
no auto-summary
============================
ip default-network 172.46.0.0
============================
sh ip route
*   172.46.0.0/30 is subnetted, 1 subnets
C*      172.46.0.0 is directly connected, Ethernet0/0
============================

都是以主类方式宣告172.46.0.0的呀?
不明白哪里出错了,怎么修改!
谢谢
15# 2013-1-10 11:41:27 回复 收起回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-5-9 14:20 , Processed in 0.085594 second(s), 23 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表