----------------R1-----------------------
R1-CE1#sh run
Building configuration...
Current configuration : 1068 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1-CE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
mpls label range 100 199
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 12.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
----------------------R2------------------------
R2-PE1#sh run
Building configuration...
Current configuration : 2107 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2-PE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf P2C
rd 1:2
route-target export 1:100
route-target import 1:100
!
mpls label range 200 299
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip vrf forwarding P2C
ip address 12.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router rip
!
address-family ipv4 vrf P2C
redistribute bgp 100 metric transparent
network 12.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 100
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
!
address-family ipv4
redistribute rip metric 1
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 next-hop-self
no auto-summary
no synchronization
network 2.2.2.2 mask 255.255.255.255
network 12.1.1.0 mask 255.255.255.0
network 23.1.1.0 mask 255.255.255.0
exit-address-family
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf P2C
redistribute rip metric 2
no synchronization
network 12.1.1.0 mask 255.255.255.0
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
R2-PE1# sh run
Building configuration...
Current configuration : 2107 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2-PE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf P2C
rd 1:2
route-target export 1:100
route-target import 1:100
!
mpls label range 200 299
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip vrf forwarding P2C
ip address 12.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router rip
!
address-family ipv4 vrf P2C
redistribute bgp 100 metric transparent
network 12.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 100
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
!
address-family ipv4
redistribute rip metric 1
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 next-hop-self
no auto-summary
no synchronization
network 2.2.2.2 mask 255.255.255.255
network 12.1.1.0 mask 255.255.255.0
network 23.1.1.0 mask 255.255.255.0
exit-address-family
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf P2C
redistribute rip metric 2
no synchronization
network 12.1.1.0 mask 255.255.255.0
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
----------------------R3-------------------------
R3-PE2#sh run
Building configuration...
Current configuration : 1850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3-PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
mpls label range 300 399
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip address 34.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 23.1.1.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 23.1.1.0 mask 255.255.255.0
network 34.1.1.0 mask 255.255.255.0
redistribute ospf 100
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 route-reflector-client
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
------------------R4------------
R4-C_PE#sh run
Building configuration...
Current configuration : 2099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4-C_PE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf P2P
rd 1:4
route-target export 1:200
route-target import 1:200
!
mpls label range 400 499
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 45.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip vrf forwarding P2P
ip address 34.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100 vrf P2P
log-adjacency-changes
redistribute bgp 200 metric 1 subnets
network 34.1.1.0 0.0.0.255 area 0
!
router ospf 110
router-id 4.4.4.4
log-adjacency-changes
redistribute bgp 200 subnets
network 4.4.4.4 0.0.0.0 area 0
network 45.1.1.0 0.0.0.255 area 0
!
router bgp 200
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 200
neighbor 6.6.6.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 110
redistribute ospf 200
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 next-hop-self
no auto-summary
no synchronization
network 4.4.4.4 mask 255.255.255.255
network 34.1.1.0 mask 255.255.255.0
exit-address-family
!
address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
exit-address-family
!
address-family ipv4 vrf P2P
redistribute ospf 100 vrf P2P metric 2
no synchronization
network 34.1.1.0 mask 255.255.255.0
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
Current configuration : 1202 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5-C_P
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
mpls label range 500 599
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 45.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
ip address 56.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 110
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 45.1.1.0 0.0.0.255 area 0
network 56.1.1.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R6-C_PE2#sh run
Building configuration...
Current configuration : 2032 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6-C_PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf P2P
rd 1:6
route-target export 1:200
route-target import 1:200
!
mpls label range 600 699
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip vrf forwarding P2P
ip address 67.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
ip address 56.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 120 vrf P2P
log-adjacency-changes
redistribute bgp 200 metric 1 metric-type 1 subnets
network 67.1.1.0 0.0.0.255 area 0
!
router ospf 110
router-id 6.6.6.6
log-adjacency-changes
redistribute bgp 200 subnets
network 6.6.6.6 0.0.0.0 area 0
network 56.1.1.0 0.0.0.255 area 0
!
router bgp 200
bgp router-id 6.6.6.6
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 200
neighbor 4.4.4.4 update-source Loopback0
!
address-family ipv4
redistribute ospf 110
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 next-hop-self
no auto-summary
no synchronization
network 6.6.6.6
network 6.6.6.6 mask 255.255.255.255
exit-address-family
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf P2P
redistribute ospf 120 vrf P2P metric 2
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
---------------------R7-----------------
R7-PE1#sh run
Building configuration...
Current configuration : 1715 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7-PE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
mpls label range 700 799
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
ip address 78.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip address 67.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 120
router-id 7.7.7.7
log-adjacency-changes
network 7.7.7.7 0.0.0.0 area 0
network 67.1.1.0 0.0.0.255 area 0
network 78.1.1.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp router-id 7.7.7.7
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 8.8.8.8 remote-as 100
neighbor 8.8.8.8 update-source Loopback0
neighbor 8.8.8.8 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
neighbor 8.8.8.8 activate
neighbor 8.8.8.8 send-community extended
neighbor 8.8.8.8 route-reflector-client
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
---------------------------R8-------------
R8-PE2#sh run
Building configuration...
Current configuration : 1879 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8-PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf P2C
rd 1:8
route-target export 1:100
route-target import 1:100
!
mpls label range 800 899
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
ip address 78.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial1/0
ip vrf forwarding P2C
ip address 89.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 300
router-id 8.8.8.8
log-adjacency-changes
network 8.8.8.8 0.0.0.0 area 0
network 78.1.1.0 0.0.0.255 area 0
!
router rip
!
address-family ipv4 vrf P2C
redistribute bgp 100 metric transparent
network 89.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 100
no synchronization
bgp router-id 8.8.8.8
bgp log-neighbor-changes
network 8.8.8.8 mask 255.255.255.255
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 update-source Loopback0
neighbor 7.7.7.7 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
exit-address-family
!
address-family ipv4 vrf P2C
redistribute rip
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
---------------R9--------------------
R9-CE2#sh run
Building configuration...
Current configuration : 1043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R9-CE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 89.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 9.0.0.0
network 89.0.0.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end