设为首页收藏本站language→→ 语言切换

鸿鹄论坛

 找回密码
 论坛注册

QQ登录

先注册再绑定QQ

查看: 6871|回复: 4
收起左侧

[RS] 命名EIGRP基本配置

[复制链接]
发表于 2014-6-4 12:06:27 | 显示全部楼层 |阅读模式

命名EIGRP

命名EIGRP

1.基本配置
R1(config)#interface loopback 0
R1(config-if)#ip address 172.16.0.1 255.255.255.0
R1(config-if)#interface loopback 1
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#interface loopback 2
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#interface loopback 3
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config)#interface ethernet 0/0
R1(config-if)#ip address 12.1.1.1 255.255.255.0
R1(config-if)#no shutdown

R2(config)#interface loopback 0
R2(config-if)#ip address 10.1.0.1 255.255.255.0
R2(config-if)#interface loopback 1
R2(config-if)#ip address 10.1.1.1 255.255.255.0
R2(config-if)#interface loopback 2
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#interface loopback 3
R2(config-if)#ip address 10.1.3.1 255.255.255.0
R2(config)#interface ethernet 0/0
R2(config-if)#ip address 12.1.1.2 255.255.255.0
R2(config-if)#no shutdown
2.配置命名EIGRP
R1(config)#router  eigrp TOGOGO
R1(config-router)#address-family ipv4 autonomous-system 90
R1(config-router-af)#network 12.1.1.1 0.0.0.0
R1(config-router-af)#network 172.16.0.1  0.0.0.0
R1(config-router-af)#network 172.16.1.1  0.0.0.0
R1(config-router-af)#network 172.16.2.1  0.0.0.0
R1(config-router-af)#network 172.16.3.1  0.0.0.0

R2(config)#router eigrp TOGOGO
R2(config-router)#address-family ipv4 autonomous-system 90
R2(config-router-af)#network 12.1.1.2 0.0.0.0
R2(config-router-af)#network 10.1.0.1 0.0.0.0
R2(config-router-af)#network 10.1.1.1 0.0.0.0
R2(config-router-af)#network 10.1.2.1 0.0.0.0
R2(config-router-af)#network 10.1.3.1 0.0.0.0
3.验证命令
R1#show ip eigrp neighbors
EIGRP-IPv4 VR(TOGOGO) Address-Family Neighbors for AS(90)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   12.1.1.2                Et0/0                    10 00:27:25   10   100  0  20

R2#show ip eigrp neighbors
EIGRP-IPv4 VR(TOGOGO) Address-Family Neighbors for AS(90)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   12.1.1.1                Et0/0                    10 00:26:59    9   100  0  19
4.配置EIGRP MD5认证
R1(config)#router  eigrp TOGOGO
R1(config-router)#address-family ipv4 autonomous-system 90
R1(config-router-af)#af-interface ethernet 0/0
R1(config-router-af-interface)#authentication mode md5
R1(config-router-af-interface)#authentication key-chain TOGOGO
R1(config)#key chain TOGOGO
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string cisco

R2(config)#router eigrp TOGOGO
R2(config-router)#address-family ipv4 autonomous-system 90
R2(config-router-af)#af-interface ethernet 0/0
R2(config-router-af-interface)#authentication mode md5
R2(config-router-af-interface)#authentication key-chain TOGOGO
R2(config)#key chain TOGOGO
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string cisco
5.配置IEGRP汇总路由
R1(config)#router eigrp TOGOGO
R1(config-router)#address-family ipv4 autonomous-system 90
R1(config-router-af)#af-interface ethernet 0/0
R1(config-router-af-interface)#summary-address 172.16.0.0 255.255.252.0
R2(config)#router eigrp TOGOGO
R2(config-router)#address-family ipv4 autonomous-system 90
R2(config-router-af)#af-interface ethernet 0/0
R2(config-router-af-interface)#summary-address 10.1.0.0 255.255.252.0
6.配置被动接口
R1(config)#router eigrp TOGOGO
R1(config-router)#address-family ipv4 autonomous-system 90
R1(config-router-af)#af-interface loopback 0
R1(config-router-af-interface)#passive-interface
R1(config-router-af-interface)#af-interface loopback 1
R1(config-router-af-interface)#passive-interface
R1(config-router-af-interface)#af-interface loopback 2
R1(config-router-af-interface)#passive-interface
R1(config-router-af-interface)#af-interface loopback 3
R1(config-router-af-interface)#passive-interface
R2(config)#router eigrp TOGOGO
R2(config-router)#address-family ipv4 autonomous-system 90
R2(config-router-af)#af-interface loopback 0
R2(config-router-af-interface)#passive-interface
R2(config-router-af-interface)#af-interface loopback 1
R2(config-router-af-interface)#passive-interface
R2(config-router-af-interface)#af-interface loopback 2
R2(config-router-af-interface)#passive-interface
R2(config-router-af-interface)#af-interface loopback 3
R2(config-router-af-interface)#passive-interface

7.验证配置
R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/22 is subnetted, 1 subnets
D        10.1.0.0 [90/1024640] via 12.1.1.2, 00:08:06, Ethernet0/0
      172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks
D        172.16.0.0/22 is a summary, 00:45:10, Null0
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D        10.1.0.0/22 is a summary, 00:15:09, Null0
      172.16.0.0/22 is subnetted, 1 subnets
D        172.16.0.0 [90/1024640] via 12.1.1.1, 00:08:46, Ethernet0/0

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 90"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(TOGOGO) Address-Family Protocol for AS(90)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    NSF-aware route hold timer is 240
    Router-ID: 12.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
      Total Prefix Count: 7
      Total Redist Count: 0

  Automatic Summarization: disabled
  Address Summarization:
    172.16.0.0/22 for Et0/0
      Summarizing 4 components with metric 163840
  Maximum path: 4
  Routing for Networks:
    12.1.1.1/32
    172.16.0.1/32
    172.16.1.1/32
    172.16.2.1/32
    172.16.3.1/32
  Passive Interface(s):
    Loopback0
    Loopback1
    Loopback2
    Loopback3
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.2              90      00:13:10
  Distance: internal 90 external 170




发表于 2015-4-30 14:43:01 | 显示全部楼层
楼主你好,
针对eigrp的命名式配置,我有三个不懂之处,还请指教:
问题1.支持64位的metric计算,这个如何理解?
问题2.和普通的EIGRP 5个参数值的度量值计算有何区别?
问题3.两台直连路由器,一边eigrp命名式配置方法,有接口认证(authentication mode hmac-sha-256 ccie),一边普通式配置方法,两边AS号一样,可以起邻居吗?
地板 2015-4-30 14:43:01 回复 收起回复
回复 支持 反对

使用道具 举报

 成长值: 36235
发表于 2016-5-3 11:18:09 | 显示全部楼层
何雨阳 发表于 2015-4-30 14:43
楼主你好,
针对eigrp的命名式配置,我有三个不懂之处,还请指教:
问题1.支持64位的metric计算,这个如 ...

能,
5# 2016-5-3 11:18:09 回复 收起回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )  

GMT+8, 2025-1-26 15:52 , Processed in 0.072949 second(s), 11 queries , Redis On.  

  Powered by Discuz!

  © 2001-2025 HH010.COM

快速回复 返回顶部 返回列表