路由器中间相当于公网的路由器 他们之间如何实现公司A 和公司B 的互相访问并且实现分流? 路由器上分别如何配置?
下面的是我自己配置的不知道错在哪里请各位老师指教啊
路由C 的配置:
Building configuration...
Current configuration : 1344 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 192.167.0.254 255.255.255.252
ip nat outside
shutdown
!
interface Serial3/0
ip address 192.167.0.250 255.255.255.252
ip nat outside
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
interface FastEthernet6/0
no ip address
duplex auto
speed auto
!
interface FastEthernet6/0.1
encapsulation dot1Q 1 native
ip address 192.168.2.254 255.255.255.0
ip nat inside
!
interface FastEthernet6/0.2
encapsulation dot1Q 2
ip address 192.168.1.254 255.255.255.0
ip nat inside
!
router eigrp 1
network 192.167.0.248 0.0.0.3
no auto-summary
!
router rip
version 2
network 192.167.0.0
no auto-summary
!
ip nat inside source list 1 interface Serial2/0 overload
ip nat inside source list 2 interface Serial3/0 overload
ip classless
!
!
access-list 1 permit host 192.168.2.2
access-list 2 permit host 192.168.1.1
access-list 2 permit host 192.168.1.2
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
路由器D的配置:
Building configuration...
Current configuration : 1363 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 192.167.0.253 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial3/0
ip address 192.167.0.246 255.255.255.252
ip nat outside
clock rate 64000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
interface FastEthernet6/0
no ip address
duplex auto
speed auto
!
interface FastEthernet6/0.3
encapsulation dot1Q 3
ip address 192.168.3.254 255.255.255.0
ip nat inside
!
interface FastEthernet6/0.4
encapsulation dot1Q 4
ip address 192.168.4.254 255.255.255.0
ip nat inside
!
router eigrp 1
network 192.167.0.244 0.0.0.3
no auto-summary
!
router rip
version 2
network 192.167.0.0
no auto-summary
!
ip nat inside source list 3 interface Serial2/0 overload
ip nat inside source list 4 interface Serial3/0 overload
ip classless
!
!
access-list 3 permit host 192.168.3.3
access-list 3 permit host 192.168.3.4
access-list 4 permit host 192.168.4.4
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
路由器E 的配置:
Building configuration...
Current configuration : 848 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 192.167.0.245 255.255.255.252
clock rate 64000
!
interface Serial3/0
ip address 192.167.0.249 255.255.255.252
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
interface FastEthernet6/0
no ip address
duplex auto
speed auto
shutdown
!
router eigrp 1
network 192.167.0.248 0.0.0.3
network 192.167.0.244 0.0.0.3
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end