- 积分
- 818
- 鸿鹄币
- 个
- 好评度
- 点
- 精华
- 注册时间
- 2011-7-25
- 最后登录
- 1970-1-1
- 阅读权限
- 40
- 听众
- 收听
中级工程师
|
CCNA实验:选择静态路由
1.实验目的
根据路由表转发的最长匹配原则,理解选择静态的实现方法。
2. 实验拓扑
3.实验步骤
1:先配置好各个接口的 IP 地址,保证直连能通。
在 R1 上:
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 12.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 13.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
在 R2 上
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 12.1.1.2 255.255.255.0
22
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 23.1.1.2 255.255.255.0
R2(config-if)#no shutdown
在 R3 上:
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 23.1.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 1/0
R3(config-if)#ip address 13.1.1.3 255.255.255.0
R3(config-if)#no shutdown
在 R3 上再起一个环回口,并配置多个 IP 地址:
R3(config)#interface loopback 0
R3(config-if)#ip address 33.1.1.1 255.255.255.0
R3(config-if)#ip address 33.1.1.2 255.255.255.0 secondary R3(config-if)#ip address 33.1.1.3 255.255.255.0 secondary R3(config-if)#ip address 33.1.1.4 255.255.255.0 secondary
//加 secondary 可以使一个接口配置多个辅助地址。
2:在 R1,R2,R3 上做配置,w让wR1w能.通过yR2e去spinlg 通aR3b上.的环c回o口地m址.。cn
在 R1 上:
R1(config)#ip route 33.1.1.0 255.255.255.0 12.1.1.2
在 R2 上:
R2(config)#ip route 33.1.1.0 255.255.255.0 23.1.1.3
在 R3 上配置回来的路由:
R3(config)#ip route 12.1.1.0 255.255.255.0 23.1.1.2
在 R1 上去测试是否通:
R1#traceroute 33.1.1.1
Type escape sequence to abort. Tracing the route to 33.1.1.1
1 12.1.1.2 36 msec 72 msec 32 msec
2 23.1.1.3 88 msec * 80 msec
//以上表示己经通了,并且是经过 R2。
这里我们想针对 33.1.1.1 这个 IP 地址让他走下面这条路,但是去访问 33.1.1.2,33.1.1.3,33.1.1.4 等地 址依然走上面。要实现这个功能,就要用到我们的选择路由:
在 R1 上:
R1(config)#ip route 33.1.1.1 255.255.255.255 13.1.1.3
我们去查看一下 R1 的路由表:
23
R1#show ip route
————此部分省略————
33.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
S 33.1.1.1/32 [1/0] via 13.1.1.3
S 33.1.1.0/24 [1/0] via 12.1.1.2
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, FastEthernet0/0
13.0.0.0/24 is subnetted, 1 subnets
C 13.1.1.0 is directly connected, FastEthernet1/0
//可以发现针对 33.1.1.1 这个地址我们有一条 32 位的主机路由,这时我们再访问这个地址的时候就会走 这一条而不会再选择刚才的 33.1.1.0/24 这条路由,原因是因为最长匹配的原则。
测试:
R1#traceroute 33.1.1.1
Type escape sequence to abort. Tracing the route to 33.1.1.1
1 13.1.1.3 68 msec * 44 msec
R1#traceroute 33.1.1.2
Type escape sequence to abort. Tracing the route to 33.1.1.2
1 12.1.1.2 84 msec 68 msec 40 msec
2 23.1.1.3 40 msec * 80 msec
//通过最长匹配的原则,实现了处于同一网段的 IP 包选择不同的出口。 请不要删除配置,因为接下来的实验可在此基础上实现。
|
|