鸿鹄论坛

 找回密码
 论坛注册

QQ登录

只需一步,快速开始

查看: 100|回复: 0

[分享] 华为设备配置GRE VPN

[复制链接]
 成长值: 29880
发表于 2018-10-11 13:40:27 | 显示全部楼层 |阅读模式
组网需求如图,RouterA、RouterB、RouterC属于VPN骨干网,它们之间运行OSPF。

RouterA和RouterC之间使用三层隧道协议GRE,实现PC1和PC2互联。

PC1和PC2上分别指定RouterA、RouterC为自己的缺省网关。

Tunnel接口启用动态路由协议OSPF。VPN骨干网上使用OSPF进程1,用户接入部分使用OSPF进程2。

图配置GRE使用动态路由协议组网图
1.jpg

操作步骤
1 配置RouterA
sysname RouterA
#
interface GigabitEthernet1/0/0  //配置公网出接口
ip address 20.1.1.1 255.255.255.0
#
interface GigabitEthernet2/0/0  //配置私网出接口
ip address 10.1.1.2 255.255.255.0
#
interface Tunnel0/0/1  //配置Tunnel接口,源地址是发出报文的实际接口IP地址,目的地址是接收报文的实际接口IP地址
ip address 10.3.1.1 255.255.255.0
tunnel-protocol gre
source 20.1.1.1
destination 30.1.1.2
#
ospf 1  //配置公网路由
area 0.0.0.0
  network 20.1.1.0 0.0.0.255
#
ospf 2
area 0.0.0.0  //配置私网路由
  network 10.3.1.0 0.0.0.255
  network 10.1.1.0 0.0.0.255
#
return

2 配置RouterB
sysname RouterB
#
interface GigabitEthernet1/0/0
ip address 20.1.1.2 255.255.255.0
#
interface GigabitEthernet2/0/0
ip address 30.1.1.1 255.255.255.0
#
ospf 1  //配置公网路由
area 0.0.0.0
  network 20.1.1.0 0.0.0.255
  network 30.1.1.0 0.0.0.255
#
return

3 配置RouterC
sysname RouterC
#
interface GigabitEthernet1/0/0  //配置公网出接口
ip address 30.1.1.2 255.255.255.0
#
interface GigabitEthernet2/0/0  //配置私网出接口
ip address 10.2.1.2 255.255.255.0
#
interface Tunnel0/0/1  //配置Tunnel接口,源地址是发出报文的实际接口IP地址,目的地址是接收报文的实际接口IP地址
ip address 10.3.1.2 255.255.255.0
tunnel-protocol gre
source 30.1.1.2
destination 20.1.1.1
#
ospf 1  //配置公网路由
area 0.0.0.0
  network 30.1.1.0 0.0.0.255
#
ospf 2  //配置私网路由
area 0.0.0.0
  network 10.3.1.0 0.0.0.255
  network 10.2.1.0 0.0.0.255
#
return

4 验证配置结果
# 在RouterA和RouterC上执行display ip routing-table命令,可以看到去往对端目的地址的出接口为Tunnel接口。
# PC1和PC2能互相Ping通。

配置注意事项
两段需要配置到私网的路由。
Tunnel接口的源IP和目的IP要和对端对应。


如果觉得帖子内容对你有帮助,请点击【评分】给我增加好评度,加分不会扣除自己的积分。
您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|小黑屋|手机版|Archiver|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )

GMT+8, 2018-12-12 14:06 , Processed in 0.113143 second(s), 13 queries , Gzip On, Memcache On.

Powered by Discuz! X3.4

© 2001-2018 HH010.COM

快速回复 返回顶部 返回列表