鸿鹄论坛

 找回密码
 论坛注册

QQ登录

只需一步,快速开始

查看: 222|回复: 21

[分享] 华为交换机设置基础篇

[复制链接]
 成长值: 29025
发表于 2017-7-19 10:03:13 | 显示全部楼层 |阅读模式

关于交换机和路由器的配置在教大家的时候要是用硬件是不可能的 没哪个条件今天带给大家的是我做个一个小的实验 。

大家可以下一个华为MA5200G模拟器进行实验

具体的命令和解释我全写出来了!

首先给大家收集了一些交换机的基本命令具体命令解释我已经给出了

通常命令:

PCA login: root                                     ;使用root用户

password: linux                                    ;口令是linux

# shutdown -h now                                   ;关机

# init 0                                            ;关机

# logout

# login

# ifconfig                                          ;显示IP地址

# ifconfig eth0 <ip address> netmask <netmask>      ;设置IP地址

# ifconfig eht0 <ip address> netmask <netmask> down ; 删除IP地址

# route add 0.0.0.0 gw <ip>

# route del 0.0.0.0 gw <ip>

# route add default gw <ip>                         ;设置网关

# route del default gw <ip>                         ;删除网关

# route                                             ;显示网关

# ping <ip>

# telnet <ip>                                       ;建议telnet之前先ping一下

---------------------------------------

交换机命令

~~~~~~~~~~

[Quidway]super password                                    修改特权用户密码

[Quidway]sysname                                    交换机命名

[Quidway]interface ethernet 0/1                            进入接口视图

[Quidway]interface vlan x                            进入接口视图

[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2  静态路由=网关

[Quidway]user-interface vty 0 4

[S3026-ui-vty0-4]authentication-mode password

[S3026-ui-vty0-4]set authentication-mode password simple 222

[S3026-ui-vty0-4]user privilege level 3

[Quidway-Ethernet0/1]duplex {half|full|auto}        配置端口双工工作状态

[Quidway-Ethernet0/1]speed {10|100|auto}               配置端口工作速率

[Quidway-Ethernet0/1]flow-control                     配置端口流控

[Quidway-Ethernet0/1]mdi {across|auto|normal}       配置端口MDI/MDIX状态平接或扭接

[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 设置接口工作模式

[Quidway-Ethernet0/1]shutdown                    关闭/重起接口

[Quidway-Ethernet0/2]quit                            退出系统视图

[Quidway]vlan 3                                    创建/删除一个VLAN/进入VLAN模式

[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4    在当前VLAN增加/删除以太网接口

[Quidway-Ethernet0/2]port access vlan 3                    将当前接口加入到指定VLAN

[Quidway-Ethernet0/2]port trunk permit vlan {ID|All}      设trunk允许的VLAN

[Quidway-Ethernet0/2]port trunk pvid vlan 3            设置trunk端口的PVID

[Quidway]monitor-port <interface_type interface_num>        指定和清除镜像端口

[Quidway]port mirror <interface_type interface_num>       指定和清除被镜像端口

[Quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像

[Quidway]description string                         指定VLAN描述字符

[Quidway]description                           删除VLAN描述字符

[Quidway]display vlan [vlan_id]                     查看VLAN设置

[Quidway]stp {enable|disable}                       开启/关闭生成树,默认关闭

[Quidway]stp priority 4096                          设置交换机的优先级

[Quidway]stp root {primary|secondary}               设置交换机为根或根的备份

[Quidway-Ethernet0/1]stp cost 200                   设置交换机端口的花费

[SwitchA-vlanx]isolate-user-vlan enable             设置主vlan

[SwitchA]Isolate-user-vlan <x> secondary <list>     设置主vlan包括的子vlan

[Quidway-Ethernet0/2]port hybrid pvid vlan <id>     设置vlan的pvid

[Quidway-Ethernet0/2]port hybrid pvid               删除vlan的pvid

[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged 设置无标识的vlan  

如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。

所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

计算机的命令:

计算机命令

~~~~~~~~~~

PCA login: root                                     ;使用root用户

password: linux                                    ;口令是linux

# shutdown -h now                                   ;关机

# init 0                                            ;关机

# logout

# login

# ifconfig                                          ;显示IP地址

# ifconfig eth0 <ip address> netmask <netmask>      ;设置IP地址

# ifconfig eht0 <ip address> netmask <netmask> down ; 删除IP地址

# route add 0.0.0.0 gw <ip>

# route del 0.0.0.0 gw <ip>

# route add default gw <ip>                         ;设置网关

# route del default gw <ip>                         ;删除网关

# route                                             ;显示网关

# ping <ip>

# telnet <ip>                                       ;建议telnet之前先ping一下


下面是一个小的实验具体内容做了解释

一个交换机,一个计算机,双击交换机,进入终端配置:

游客,如果您要查看本帖隐藏内容请回复

发表于 2017-7-20 09:15:39 | 显示全部楼层
好东西谢谢楼主分享
发表于 2017-7-28 11:35:16 | 显示全部楼层
不错aaaaaaa
发表于 2018-2-13 23:24:41 | 显示全部楼层
谢楼主分享
发表于 2018-2-19 22:22:12 | 显示全部楼层
aaaaaaadsadfdsaf
您需要登录后才可以回帖 登录 | 论坛注册

本版积分规则

QQ|小黑屋|手机版|Archiver|sitemap|鸿鹄论坛 ( 京ICP备14027439号 )

GMT+8, 2018-10-18 14:15 , Processed in 0.116089 second(s), 10 queries , Gzip On, Memcache On.

Powered by Discuz! X3.4

© 2001-2018 HH010.COM

快速回复 返回顶部 返回列表